Задать вопрос
27 февраля, 14:45

Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному.

Входные данные

В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M (1 ≤ N, M ≤ 100). В следующих N строках записаны строки матрицы, в каждой - по M натуральных чисел, разделённых пробелами.

Выходные данные

Программа должна вывести все столбцы, в которых есть элемент, равный максимальному элементу в матрице. Каждый столбец выводится в одну строку, элементы разделяются пробелами.

+4
Ответы (1)
  1. 27 февраля, 15:22
    -1
    Pascal

    program matr; uses CRT; var fl:char; a:array [1 ... 100,1 ... 100] of integer; i, j, m, n, mmax:byte; max:integer; label met; beginmet:clrscr; max:=0; writeln ('Введите размерность матрицы NxM') ; readln (n) ; readln (m) ; randomize; for i:=1 to n do beginfor j:=1 to m do begina[i, j]:=-50+random (101) ; write (a[i, j]:4) ; end; {создание и вывод матрицы}writeln; end; writeln; for i:=1 to n do{нахождение максимального элемента}zfor j:=1 to m doif (a[i, j]>max) then beginmax:=a[i, j]; mmax:=j; end; for i:=1 to n dowrite (a[i, mmax]:4) ; writeln; {Вывод столбца}for i:=1 to n do {нахождение одинаковых элементов}for j:=1 to n doif (a[i, j]=max) and (jmmax) then begin mmax:=j; write (a[i, mmax]:4) ; end; writeln ('Для продолжения нажмите любую клавишу, для выхода - "Х"') ; readln (fl) ; if (fl 'x') then goto met; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая находит в матрице столбцы, в которых есть элемент, равный максимальному. Входные данные В первой строке ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая обнуляет все элементы квадратной матрицы, расположенные выше главной диагонали. Входные данные В первой строке записаны через пробел размер квадратной матрицы N (количество строк равно количеству столбцов) (1 ≤ N ≤ 100).
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Python! Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)