Задать вопрос
15 января, 20:55

Всем Привет! 1. В текстовом файле хранятся квадратные целочисленные матрицы

порядка n. Преобразовать

файл, удалив из каждой матрицы элементы побочной диагонали.

+3
Ответы (1)
  1. 15 января, 22:59
    0
    Const

    n = 3;

    type

    M = array[1 ... 3, 1 ... 3] of integer;

    var

    i, j: integer;

    f: Text;

    a, b: M;

    s:string;

    begin

    Assign (f, 'input. dat') ;

    Reset (f) ;

    writeln ('Считываемые данные') ;

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    begin

    read (f, a[i, j]) ;

    write (a[i, j]:4)

    end;

    writeln

    end;

    writeln;

    for i : = 1 to n do

    begin

    for j : = 1 to n do

    begin

    read (f, b[i, j]) ;

    write (b[i, j]:4)

    end;

    writeln

    end;

    Close (f) ;

    Rewrite (f) ;

    for i : = 1 to n do

    for j : = 1 to n do

    if j n + 1 - i then

    write (f, a[i, j], ' ') ;

    writeln (f) ;

    for i : = 1 to n do

    for j : = 1 to n do

    if j n + 1 - i then

    write (f, b[i, j], ' ') ;

    writeln (f) ;

    Close (f) ;

    Reset (f) ;

    writeln ('Данные, перезаписанные в файл') ;

    while not eof (f) do

    begin

    readln (f, s) ;

    writeln (s)

    end;

    Close (f) ;

    writeln

    end.

    Тестовое решение:

    Считываемые данные

    2 3 7

    4 3 1

    8 9 6

    14 3 12

    5 - 2 8

    6 0 13

    Данные, перезаписанные в файл

    2 3 4 1 9 6

    14 3 5 8 0 13
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Всем Привет! 1. В текстовом файле хранятся квадратные целочисленные матрицы порядка n. Преобразовать файл, удалив из каждой матрицы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)
Перед вами часть кода программы на языке Pascal. sum:=0; for i:=1 to n do for j:=1 to n do if (i
Ответы (1)
Даны две целочисленные квадратные матрицы порядка n и m. Найти для каждой номера строк, все элементы которых нули.
Ответы (1)
Почему файл, созданный в Word 2007, имеет расширение. docm? Вариант 1 файл предназначен для пересылки по электронной почте Вариант 2 файл содержит вирусы Вариант 3 файл создан на основе шаблона Вариант 4 файл содержит макросы
Ответы (1)
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)