Задать вопрос
7 октября, 15:37

Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а

+4
Ответы (1)
  1. 7 октября, 17:30
    0
    var f, g:string;

    i:integer;

    begin

    readln (f) ;

    for i:=1 to length (f) - 1 do if (f[i+1]='а') then g:=g+f[i];

    writeln (g) ;

    g:='';

    for i:=2 to length (f) do if (f[i-1]='а') then g:=g+f[i];

    writeln (g) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Имеются два файла одинакового размера элементами которого являются отдельные символы. Переписать с сохранением порядка следования элементы первого файла во второй а элементы второго файла в первый. использовать вспомогательный файл.
Ответы (1)
Pascal ABC Дан текстовый файл t1. txt, содержащий целые числа, не превышающие 30000. Найти длину самой длинной цепочки одинаковых чисел, идущих подряд в файле t1. txt и записать эту цепочку в файл t2.
Ответы (1)
Почему файл, созданный в Word 2007, имеет расширение. docm? Вариант 1 файл предназначен для пересылки по электронной почте Вариант 2 файл содержит вирусы Вариант 3 файл создан на основе шаблона Вариант 4 файл содержит макросы
Ответы (1)
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Фоксфорд олимпиада по информатикеПервый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)