Задать вопрос
9 июня, 08:43

Имеются два файла одинакового размера элементами которого являются

отдельные символы. Переписать с сохранением порядка следования элементы

первого файла во второй а элементы второго файла в первый. использовать

вспомогательный файл. (написать в паскале надо программу)

+4
Ответы (1)
  1. 9 июня, 11:08
    0
    Const n1='file1'; n2='file2'; n3='file3';

    var f1, f2, f3:file of char; c:char;

    begin

    assign (f1, n1) ; assign (f2, n2) ; assign (f3, n3) ;

    reset (f1) ; rewrite (f3) ;

    while not (eof (f1)) do begin read (f1, c) ; write (f3, c) end;

    close (f1) ; close (f3) ;

    reset (f2) ; rewrite (f1) ;

    while not (eof (f2)) do begin read (f2, c) ; write (f1, c) end;

    close (f1) ; close (f2) ;

    reset (f3) ; rewrite (f2) ;

    while not (eof (f3)) do begin read (f3, c) ; write (f2, c) end;

    close (f3) ; close (f2) ;

    erase (f3)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Имеются два файла одинакового размера элементами которого являются отдельные символы. Переписать с сохранением порядка следования элементы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Фоксфорд олимпиада по информатикеПервый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Дан текстовый файл с именем input. txt в первой строке которого записано натуральное число N, а во второй строке N целых чисел. Переписать в файл с именем a. dat числа, кратные 100 из исходного файла, а в файл с именем b.
Ответы (1)
Дан символьный файл f. Записать в файле g, с сохранением порядка их следования, те символьные данные: a) которым в файле f предшествует буква а б) в след за которыми в файле f идёт буква а
Ответы (1)
Задача: написать программу на Паскале, С (С++) или Бейсике. Входной файл: input. txt. Выходной файл: output. txt. Ограничение времени выполнения программы: 1 секунда на тест.
Ответы (1)