Задать вопрос
31 октября, 12:56

Напишите программу (Pascal)

Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.

+3
Ответы (1)
  1. 31 октября, 14:42
    0
    Program n1;

    var sum, a, c: integer;

    begin

    readln (a) ;

    sum:=0;

    while true do

    begin

    readln (c) ;

    if c=0 then break;

    if c mod a=0 then sum:=sum+c;

    end;

    writeln (sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу (Pascal) Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу a.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Дано N целых чисел, полученных от датчика случайных чисел в диапазоне от - 1000 до 1000. В цикле for найти среднее значение чисел, кратных числу M, заданному с клавиатуры. Результаты выдать на экран. pascal
Ответы (1)
Помогите! 1) Составь программу для решения уравнения ax=b, произвольно вводимых с клавиатуры a и b. 2) Написать программу, которая вычисляет сумму нечетных чисел от 11 и до n задаваемого клавиатуры, но больше 11
Ответы (2)