Задать вопрос
14 ноября, 11:07

Помогите!

1) Составь программу для решения уравнения ax=b, произвольно вводимых с клавиатуры a и b.

2) Написать программу, которая вычисляет сумму нечетных чисел от 11 и до n задаваемого клавиатуры, но больше 11

+5
Ответы (2)
  1. 14 ноября, 11:12
    0
    Вот так понятнее будет)))

    p. s. это первое
  2. 14 ноября, 13:35
    0
    2.

    var n, s, i:integer;

    begin

    writeln ('Программа, которая вычисляет сумму нечетных чисел от 11 и до n, задаваемого клавиатуры (n>11) ') ;

    write ('Введите n: ') ;

    readln (n) ;

    for i:=11 to n do

    if i mod 2 = 1 then s:=s+i;

    writeln ('Сумма нечетных чисел от 11 до ', n,' равна ', s)

    end.

    1.

    var a, b:real;

    begin

    writeln ('Программа для решения уравнения ax=b') ;

    write ('Введите a и b: ') ;

    readln (a, b) ;

    if (a=0) and (b=0) then writeln ('x - любое число')

    else if (a=0) and (b0) then writeln ('решений нет')

    else writeln ('x = ', b/a)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! 1) Составь программу для решения уравнения ax=b, произвольно вводимых с клавиатуры a и b. 2) Написать программу, которая ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. Составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2.
Ответы (1)
1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры. 3.
Ответы (1)
1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt. 2.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)