Задать вопрос
30 мая, 21:53

1. Составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2. Составить программу, которая вычисляет сколько лет можно выполнять план по отлову рыбы, если запасы рыбы составляют а тонн, ежегодный прирост рыбы 25%, ежегодный план отлова с тонн.

PascalABC

+4
Ответы (1)
  1. 31 мая, 01:09
    0
    1)

    Program n1;

    var sum, k, a: integer;

    begin

    sum:=0;

    k:=0;

    readln (a) ;

    while a0 do

    begin

    sum:=sum+a;

    k:=k+1;

    readln (a) ;

    end;

    write ('сумма: ', sum,'; срзнач: ', sum/k) ;

    end.

    2)

    Program n2;

    var a, c, sum: real;

    k: integer;

    begin

    k:=1;

    readln (a, c) ;

    sum:=a;

    repeat

    sum:=sum+a*0.25;

    k:=k+1;

    until sum>=c;

    write (k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составить программу, которая вычисляет сумму и среднее арифметическое чисел вводимых с клавиатуры, пока не будет введено число 0. 2. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запасы рыбы оценены в А тонн. Ежегодный прирост рыбы в пруду 15%. ежегодный план отлова В тонн, наименьший запас рыбы составляет С тонн (запас ниже С тонн уже не восстанавливается).
Ответы (1)
Ежегодный прирост рыбы в пруду 15%. Запасы рыбы оценены в А тонн, ежегодный план отлова В тонн, наименьший запас, ниже которого запас уже не восстанавливается составляет С тонн. Сколько лет можно выдержать заданный план?
Ответы (1)
Запас рыбы в пруду оценен в А тонн. Ежегодный прирост рыбы составляет 15%. Ежегодный план отлова - В тонн. Наименьший запас рыбы составляет С тонн. (Запас ниже С тонн не восстанавливается.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)