Задать вопрос
5 августа, 20:51

1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с клавиатуры. Результаты работы программы записываются в файл Out. txt.

2. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся из файла Input. txt. Результаты работы программы добавляются в файл Out. txt.

+2
Ответы (1)
  1. 5 августа, 23:52
    0
    var a, b, sum, i:int64; begin assign (input,'input. txt') ; assign (output,'out. txt') ; reset (input) ; rewrite (output) ; readln (a) ; b:=2; i:=1; repeat begin sum:=sum+b; b:=b+2; i:=i+1; end; until i=a+1; writeln (sum) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Написать программу, которая вычисляет сумму первых N четных положительных чисел. Исходные данные (N - количество чисел) вводятся с ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
1. Задан полный путь к файлу C:/Мои документы/доклад. txt Каково полное имя файла? а) C: / Мои документы/доклад. txt б) Мои документы/доклад. txt в) доклад г) доклад. txt 2. Задан полный путь к файлу C:/Мои документы/доклад.
Ответы (2)
Даны два файла: input. txt и output. txt. В input. txt дана последовательность чисел: 1,6,11,16,21. В Output. txt отобразить размах ряда (т. е разность между наибольшим и наименьшим числом). Pascal
Ответы (1)
Решето Эратосфена в PascalABC Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия.
Ответы (1)