Задать вопрос
20 марта, 01:58

1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел.

2. Составить программу на языке Паскаль вычисления кубов чисел вводимых с клавиатуры.

3. Написать программу вычисления положительных чисел. Записать варианты программы с разными видов циклов.

+2
Ответы (1)
  1. 20 марта, 03:39
    0
    Первая:

    Uses crt;

    Var arr:array[1 ... 100] of integer;

    n, a, c:integer;

    Begin

    Write ('Сколько чисел вы хотите ввести?-') ;

    Readln (n) ;

    for a:=1 to n do

    begin

    Write ('Введите ', a,' число:') ;

    Readln (arr[a]) ;

    end; c:=0;

    For a:=1 to n do

    Begin

    if (arr[a] mod 20) and (arr[a]<0) then c:=c+1;

    end;

    Writeln ('В последовательности ', c,' нечетных отрицательных чисел.') ;

    end.

    Вторая:

    Uses crt;

    Var arr:array[1 ... 100] of integer;

    a, b, c, m:integer;

    begin

    Write ('Сколько чисел вы хотите ввести?-') ;

    Readln (b) ;

    For a:=1 to b do

    begin

    Write ('Введите ', a, ' число:') ;

    Readln (arr[a]) ;

    end;

    For a:=1 to b do

    Begin

    m:=arr[a];

    For c:=1 to 2 do

    begin

    arr[a]:=m*arr[a];

    end; end;

    For a:=1 to b do

    begin

    Writeln ('Куб ', a,' введенного вами числа равен:', arr[a]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. с клавиатуры вводится n действительных чисел. Определить сколько в данной последовательности нечетных отрицательных чисел. 2. Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Составьте программу на языке Паскаль для следующих задач: 1. Найдите сумму всех чисел от a до 500 (значение a вводится с клавиатуры; a≤500). 2. Найдите среднее арифметическое всех целых чисел от a до b (значение a и b вводится с клавиатуры; a≤b). 3.
Ответы (1)
Дана последовательность чисел, вводимых с клавиатуры и оканчивающаяся нулем. Составьте программу вычисления: a. суммы всех чисел последовательности; b. среднего арифметического всех чисел последовательности: c.
Ответы (1)
1. Построить и записать в виде программы алгоритм вычисления суммы квадратов десяти произвольных чисел, вводимых с клавиатуры в процессе выполнения программы. 2. Вводятся 15 чисел. Определить, сколько среди целых чисел. 3.
Ответы (1)