Задать вопрос
13 октября, 18:54

Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу a.

+5
Ответы (1)
  1. 13 октября, 22:36
    0
    Program gt;

    var n, a, i, s, q:integer;

    begin

    read (n) ;

    read (a) ;

    s:=0;

    for i:=1 to n do

    begin

    read (q) ;

    if (q mod a=0) then s:=s+q;

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу pascal: найти сумму всех чисел с клавиатуры, кратных заданному числу a. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу (Pascal) Найдите сумму всех вводимых с клавиатуры чисел, кратных заданному числу а.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Дано N целых чисел, полученных от датчика случайных чисел в диапазоне от - 1000 до 1000. В цикле for найти среднее значение чисел, кратных числу M, заданному с клавиатуры. Результаты выдать на экран. pascal
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)