Задать вопрос
14 февраля, 18:04

Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В.

Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна.

pascal abc

+4
Ответы (1)
  1. 14 февраля, 19:27
    0
    1) var a:array[1 ... 3,1 ... 3] of integer;

    b:array[1 ... 3,1 ... 3] of integer;

    c:array[1 ... 3,1 ... 3] of integer;

    i, j:integer;

    begin;

    writeln ('A array:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    a[i, j]:=random (10) - 10;

    write (a[i, j]:4) ;

    end;

    end;

    writeln;

    writeln ('B array:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    b[i, j]:=random (-10,10) ;

    write (b[i, j]:4) ;

    end;

    end;

    writeln;

    writeln ('C array:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    c[i, j]:=a[i, j]*b[i, j];

    write (c[i, j]:4) ;

    end;

    end;

    end.

    2) var a:array[1 ... 1000,1 ... 1000] of integer;

    i, j, k, n, u:integer;

    begin;

    randomize;

    readln (n) ;

    writeln ('A array:') ;

    for i:=1 to n do begin;

    writeln;

    for j:=1 to n do

    begin;

    a[i, j]:=random (10) - 10;

    write (a[i, j]:4) ;

    end;

    end;

    for i:=1 to n do begin;

    for j:=1 to n do

    u+=a[i, j];

    if u<0 then inc (k) ;

    u:=0;

    end;

    writeln;

    write ('Result:', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)
1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC.
Ответы (1)
Составить и отладить программу обработки матрицы размерности n*n. Выполнить программу для n=4. Подсчитать сумму элементов матрицы стоящих над главной диагональю в Pascal
Ответы (1)