Задать вопрос
4 мая, 00:31

1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А.

2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.

+4
Ответы (1)
  1. 4 мая, 01:21
    0
    1) var ma:array[1 ... 3,1 ... 3] of integer;

    i, j, t:integer;

    begin;

    randomize;

    readln (t) ;

    writeln ('Matrix:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    ma[i, j]:=random (10) ;

    write (ma[i, j]:4) ;

    ma[i, j]:=ma[i, j]*t;

    end;

    end;

    writeln;

    writeln ('Final matrix:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    write (ma[i, j]:4) ;

    end;

    end.

    2) var ma:array of array of real;

    i, j, n, m, maxj, maxi:integer;

    max:real;

    begin;

    readln (n) ;

    readln (m) ;

    setlength (ma, n+1) ;

    for i:=1 to n do

    setlength (ma[i], m+1) ;

    max:=-2147483648;

    writeln ('Matrix:') ;

    for i:=1 to n do

    begin;

    writeln;

    for j:=1 to m do

    begin;

    ma[i, j]:=random (100) - 50;

    write (ma[i, j]:4) ;

    if (ma[i, j]max) then

    begin;

    max:=ma[i, j];

    maxi:=i;

    maxj:=j;

    end;

    end;

    end;

    writeln;

    writeln ('Max:', max) ;

    writeln ('Строка:', maxi) ;

    write ('Столбец:', maxj) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)
Дана вещественная квадратная матрица А, размерностью n*n. Найти сумму элементов матрицы, расположенных под главной диагональю
Ответы (1)
написать программу нахождения максимального числа, где должны быть: 1. ввод 10 чисел с клавиатуры 2. их перебор с нахождением максимального элемента 3. вывод значения максимального элемента в текстовый файл (программа должна его создать)
Ответы (1)
Для матрицы размером в n строк и m столбцов составить алгоритм и программу вычисления: 1) Сумм элементов каждой нечетной строки матрицы 2) Суммы произведений тангенсов элементов четных строк матрицы.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)