Задать вопрос
28 октября, 04:53

Дана вещественная квадратная матрица А, размерностью n*n. Найти сумму элементов матрицы, расположенных под главной диагональю

+2
Ответы (1)
  1. 28 октября, 05:55
    0
    Program gt;

    var n, i, j:integer;

    a:array[1 ... 100,1 ... 100]of real;

    s:real;

    begin

    readln (n) ;

    for i:=1 to n do

    for j:=1 to n do

    begin

    read (a[i, j]) ;

    if (i=j) then s:=s+a[i, j];

    end;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана вещественная квадратная матрица А, размерностью n*n. Найти сумму элементов матрицы, расположенных под главной диагональю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
Дана вещественная матрица А, размерностью n*n. Найти сумму элементов матрицы, расположенных на главной диагонали.
Ответы (1)
ПаскальАВС. №1. Вычислить сумму и число положительных элементов матрица А[N, N], находящихся над главной диагональю. №2. Дана вещественная матрица А размера n x m.
Ответы (1)
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)
6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.
Ответы (1)