Задать вопрос
21 мая, 08:50

6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А.

Дана вещественная матрица А (N. M). Составить программу замены всех отрицательных элементов матрицы на элемент, имеющий максимальное значение.

+3
Ответы (1)
  1. 21 мая, 11:17
    0
    1) var a:array[1 ... 3,1 ... 3] of integer;

    b:array[1 ... 3,1 ... 3] of integer;

    c:array[1 ... 3,1 ... 3] of integer;

    i, j:integer;

    begin;

    writeln ('A array:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    a[i, j]:=random (-10,10) ;

    write (a[i, j]:4) ;

    end;

    end;

    writeln;

    writeln ('B array:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    b[i, j]:=random (-10,10) ;

    write (b[i, j]:4) ;

    end;

    end;

    writeln;

    writeln ('C array:') ;

    for i:=1 to 3 do

    begin;

    writeln;

    for j:=1 to 3 do

    begin;

    c[i, j]:=b[i, j]-a[i, j];

    write (c[i, j]:4) ;

    end;

    end;

    end.

    2) var a:array of array of real;

    i, j, n, m:integer;

    max:real;

    begin;

    randomize;

    max:=-2147483648;

    readln (n) ;

    readln (m) ;

    setlength (a, n+1) ;

    for i:=1 to n do

    setlength (a[i], m+1) ;

    writeln ('A array:') ;

    for i:=1 to n do

    begin;

    writeln;

    for j:=1 to m do

    begin;

    a[i, j]:=random (-10,10) ;

    if max
    write (a[i, j]:4) ;

    end;

    end;

    for i:=1 to n do

    for j:=1 to m do

    if a[i, j]<0 then a[i, j]:=max;

    writeln;

    writeln ('Final array:') ;

    for i:=1 to n do

    begin;

    writeln;

    for j:=1 to m do

    write (a[i, j]:4) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «6 вариант. Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С = В - А. Дана вещественная матрица А (N. M). Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Даны квадратная матрицы А размером 3 х3 и число t. Требуется найти С=t*А. 2) Дана вещественная матрица А (N, M). Составить программу нахождения максимального отрицательного элемента матрицы и нахождения его местоположения.
Ответы (1)
Дана матрица размерностью nxn найти Дана матрица размерностью nxn найти минимальный элемент среди элементов расположенных над главной диагональю матрицы.
Ответы (1)
1) Дана матрица размером M * N. В каждой строке матрицы найти минимальный элемент и максимальный из найденного. 2) дана матрица размерами N * N. Поменять местами столбец с максимальным и столбец содержащий минимальное количество нулевых элементов.
Ответы (1)
ПаскальАВС. №1. Вычислить сумму и число положительных элементов матрица А[N, N], находящихся над главной диагональю. №2. Дана вещественная матрица А размера n x m.
Ответы (1)
Даны две квадратные матрицы А и В размером 3 х3. Требуется найти С=А х В. Составить программу нахождения числа строк матрицы А (N, N), сумма элементов у которых отрицательна. pascal abc
Ответы (1)