Задать вопрос
21 августа, 18:58

Каким образом можно записать функцию вычисляющую остаток от деления в C++.

Например, нужно найти остаток от деления 100 на 7

+1
Ответы (1)
  1. 21 августа, 21:54
    0
    Вообще, в С + + под эту задачу предусмотрен оператор "%".

    Но, если Вам нужно именно функция, то вот:

    #include

    int MOD (int var1, int var2)

    {

    return var1 % var2;

    }

    int main ()

    {

    std::cout << MOD (100, 7) << std::endl;

    }

    Что эквивалентно std:: cout << 100 % 7 << std::endl;
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Каким образом можно записать функцию вычисляющую остаток от деления в C++. Например, нужно найти остаток от деления 100 на 7 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Умоляю, помогите с Паскалем 1. Пользователь вводит неотрицательное однозначное число A. Написать программу: вычисляющую в случае ввода 1 - площадь круга с радиусом A, вычисляющую в случае ввода 2 - площадь квадрата со стороной A, вычисляющую в
Ответы (1)
Задание #1 Напиши программу, вычисляющую периметр и площадь прямоугольника. Используй для этого длину и ширину прямоугольника, которые вводятся с клавиатуры.
Ответы (1)
1. Написать программу, вычисляющую сумму отрицательных чисел, кратных 5, среди пяти, вводимых с клавиатуры. 2. Написать программу, вычисляющую произведение чисел, оканчивающихся цифрами 2 и 4, среди пяти, вводимых с клавиатуры. 3.
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)