Задать вопрос
12 октября, 21:57

задача на паскале: четырёх значное число, которое раскладывается по цифрам, находится произведение, сумма, большое число из них

+2
Ответы (1)
  1. 12 октября, 22:21
    0
    Program p1;

    uses crt;

    var a, ed, des, sot, tis, s, p, max:longint;

    begin

    clrscr;

    writeln ('введите четырех значное число') ;

    readln (a) ;

    ed:=a mod 10;

    des:=a div 10 mod 10;

    sot:=a div 100 mod 10;

    tis:=a div 1000;

    s:=0; p:=1;

    p:=ed*des*sot*tis;

    s:=ed+des+sot+tis;

    writeln ('Произведение чисел = ', p) ;

    writeln ('Сумма чисел = ', s) ;

    if (ed>des) and (ed>sot) and (ed>tis) then max:=ed;

    if (des>ed) and (des>sot) and (des>tis) then max:=des;

    if (sot>ed) and (sot>des) and (sot>tis) then max:=sot;

    if (tis>ed) and (tis>des) and (tis>sot) then max:=tis;

    writeln ('Максимальное число = ', max) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «задача на паскале: четырёх значное число, которое раскладывается по цифрам, находится произведение, сумма, большое число из них ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа. Формат ввода: в входном файле находится одно четырех значное число.
Ответы (1)
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная. Формат ввода В входном файле находится одно четырехзначное число.
Ответы (1)
Помогите решить в паскале 1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6. 2) Введено 3-значное число.
Ответы (1)
Если 777 умножить на 143 то получиться 6 значное число записоными 1 придумоете число которое умножить на 777 плучится 6 значное записаное 2,3, 4,5,6,7,8,9.
Ответы (1)
Объясните. Я нахожусь в дома, дом находится на улице, улица находится в городе, город находится в стране, страна находится на континенте, континент находится в космосе, космос находится во Вселенной. А где находится Вселенная?
Ответы (2)