Задать вопрос
2 марта, 15:04

Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная.

Формат ввода

В входном файле находится одно четырехзначное число.

Формат вывода

В выходной файл следует вывести сообщение "YES", если сумма цифр число четная или "NO", если сумма не четная.

+3
Ответы (1)
  1. 2 марта, 17:27
    0
    Var

    a:array[1 ... 4] of integer;

    s, i:integer;

    begin

    while i < 4 do begin

    i+=1;

    read (a[i]) ;

    s+=a[i];

    end;

    if frac (s/2) = 0 then write ('yes')

    else write ('not') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная. Формат ввода В входном файле находится одно ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа. Формат ввода: в входном файле находится одно четырех значное число.
Ответы (1)
Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных данных: Во входном файле input.
Ответы (1)
Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Написать программу на паскале. Для того чтобы проверить, как ее ученики умеют считать, Мария Ивановна каждый год задает им на дом одну и ту же задачу - "Для заданного натурального A найти минимальное натуральное N такое, что N в степени N (N,
Ответы (1)