Задать вопрос
26 августа, 16:52

Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа. Формат ввода: в входном файле находится одно четырех значное число. Формат вывода: в выходной файл следует вывести сообщение "YES", если сумма цифр число четная или "NO", если сумма не четная.

+4
Ответы (1)
  1. 26 августа, 19:30
    0
    Язык C++.

    #include

    using namespace std;

    int main () {

    int n, sum;

    cout << "Введите четырехзначное число: "<< endl;

    cin >> n;

    if (n > 10000 || n < 999) {

    cout << "Число не четырехзначное." << endl;

    }

    else {

    while (n!=0) {

    sum + = n%10;

    n / = 10;

    }

    if (sum%2 = = 0) {

    cout << "YES" << endl;

    }

    else{

    cout << "NO" << endl;

    }

    }

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа. Формат ввода: в входном файле находится одно четырех ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано четырех значное число. Нужно проверить является ли сумма цифр заданного числа четная. Формат ввода В входном файле находится одно четырехзначное число.
Ответы (1)
Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.
Ответы (1)
Написать программу в Паскале. По заданному числу N определите знак числа. Формат входных данных: Во входном файле input.
Ответы (1)
Дано слово. Записать каждый символ по два раза. Формат ввода: s - слово Формат вывода: s1 - новое слово Пример ввода: дождь Пример вывода: ддоожжддьь
Ответы (1)
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)