Задать вопрос
26 февраля, 17:35

Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes и сумму элементов строки N1. Если НЕТ - вывести No и сумму элементов строки N2.

Формат ввода:

N M (N<=10, M<=12)

a[1,1] a[1,2] ... a[1, M]

a[2,1] a[2,2] ... a[2, M]

...

a[N, 1] a[N, 2] ... a[N, M]

N1 N2

Пример ввода:

3 4

1 2 3 4

1 2 3 4

1 2 4 4

1 2

Пример ввода:

3 4

1 2 3 4

1 2 3 5

1 2 3 4

1 2

Формат вывода:

Yes SumN1

или

No SumN2

Пример вывода:

Yes 10

Пример вывода:

No 11

SumN1 - сумма всех элементов строки N1

SumN2 - сумма всех элементов строки N2

+4
Ответы (1)
  1. 26 февраля, 19:35
    0
    Var a:array[1 ... 10,1 ... 12] of integer;

    n, m, n1, n2, i, j, s1, s2:integer;

    b:boolean;

    begin

    readln (n, m) ;

    for i:=1 to n do

    for j:=1 to m do read (a[i, j]) ;

    readln (n1, n2) ;

    s1:=0; s2:=0; b:=true;

    for j:=1 to m do

    begin

    s1:=s1+a[n1, j]; s2:=s2+a[n2, j];

    if a[n1, j]a[n2, j] then b:=false;

    end;

    if b then write ('YES, s1 = ', s1) else write ('NO, s2 = ', s2) ;

    end.

    Пример:

    3 4

    1 2 3 4

    2 3 1 4

    1 2 3 4

    1 3

    YES, s1 = 10
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задан двумерный массив, имеющий N строк и M столбцов. Определите, является ли строка номер N1 равной строке номер N2. Если ДА - вывести Yes ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)
Задан двумерный массив A из 5-ти строк и 2-х столбцов. Составить программу, которая формирует одномерный массив В, каждый элемент которого есть произведение элементов массива A в строке.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
2. Задать двумерный массив (4 х4) случайными значениями от 12 до 18 включительно. Вывести сумму значений элементов каждого столбца матрицы. 3. Задать двумерный массив (7 х7) случайными значениями от 12 до 18 включительно.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)