Задать вопрос
4 сентября, 18:14

Дано слово. Записать каждый символ по два раза.

Формат ввода: s - слово

Формат вывода: s1 - новое слово

Пример ввода: дождь

Пример вывода: ддоожжддьь

+5
Ответы (1)
  1. 4 сентября, 19:26
    0
    Var s, s1:string;

    i:integer;

    begin

    write ('Введите слово: ') ;

    readln (s) ;

    s1:='';

    for i:=1 to length (s) do s1:=s1+s[i]+s[i];

    writeln (s1) ;

    end.

    Пример:

    Введите слово: дождь

    ддоожжддьь
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано слово. Записать каждый символ по два раза. Формат ввода: s - слово Формат вывода: s1 - новое слово Пример ввода: дождь Пример вывода: ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)
1. Верное высказывание: а) Принтер - устройство ввода/вывода б) CD - ROM - устройство вывода в) Компакт-диск - устройство для хранения информации г) Клавиатура устройство ввода/вывода д) Монитор - устройство ввода
Ответы (1)
У белки было s1 орехов и s2 грибов. Она съела все грибы и s3 орехов. Сколько орехов у неё осталось? Формат ввода: s1 - количество орехов. s2 - количество грибов. s3 - количество съеденных орехов. Формат вывода: d - количество оставшихся орехов.
Ответы (1)
Укажите алгоритмы устранения следующих ошибок: 1) Установить курсор на место вставки. 2) Нажать клавишу с нужным символом. Что это Лишний символ, пропущенный символ, неверный символ? 1) Установить курсор за ошибочным символом.
Ответы (1)
Серёжа мечтает о том, что бы каждый второй символ был #. Он пытался написать программу, которая вводила строку, а потом выводила вместе каждого второго символа "#", но у него не получилось этого сделать. Помогите ему осуществить свою мечту.
Ответы (1)