Задать вопрос
16 ноября, 14:03

Серёжа мечтает о том, что бы каждый второй символ был #. Он пытался написать программу, которая вводила строку, а потом выводила вместе каждого второго символа "#", но у него не получилось этого сделать. Помогите ему осуществить свою мечту.)))

Формат ввода: вводится строка

Формат вывода: выводится строка, где каждый второй символ заменён нам "#"

Пример ввода: Milye druz'ya

Пример вывода: M#l#e#d#u#'#a

+3
Ответы (1)
  1. 16 ноября, 15:22
    0
    Var

    s:string;

    i:byte;

    begin

    Write ('Введи строку: ') ; Readln (s) ;

    i:=2;

    while i<=length (s) do begin s[i]:='#'; i:=i+2 end;

    Writeln (s)

    end.

    Тестовое решение:

    Введи строку: Milye druz'ya

    M#l#e#d#u#'#a
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Серёжа мечтает о том, что бы каждый второй символ был #. Он пытался написать программу, которая вводила строку, а потом выводила вместе ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая будет читать любую строку, а затем выводить ее на экран. Формат ввода: s - строка Формат вывода: s - строка Пример ввода: I am a string. Пример вывода: I am a string.
Ответы (1)
Дано слово. Записать каждый символ по два раза. Формат ввода: s - слово Формат вывода: s1 - новое слово Пример ввода: дождь Пример вывода: ддоожжддьь
Ответы (1)
Буквоеды - опасные существа, которые обкусывают слово с двух сторон. Продемонстрируйте этот процесс. Формат ввода Вводится одна строка.
Ответы (1)
Pascal ABC Напишите программу, которая будет читать строку и число (номер), а затем выводить из этой строки символ с указанным номером.
Ответы (1)
1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку 3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее
Ответы (1)