Задать вопрос
22 августа, 13:53

1) дана строка S определить и напечатать сколько символов *

2) дана строка S вместо каждого символа * записать символы 0 Напечатать полученную строку

3) дана строка S получить и напечатать строку Т образуемую путем прочтения строки S начиная с ее конца

4) дана строка S в которой есть одна открывающаяся скобку и одна закрывающаяся скобку Удалить все символы между этими скобками

+5
Ответы (1)
  1. 22 августа, 14:42
    0
    1)

    var s:string; i, k:integer;

    begin

    read (s) ;

    for i:=1 to length (s) do

    if s[i]='*' then k:=k+1;

    writeln (k) ;

    end.

    2)

    var s:string; i:integer;

    begin

    read (s) ;

    for i:=1 to length (s) do

    if s[i]='*' then begin delete (s, i, 1) ; insert ('0', s, i) ; end;

    writeln (s) ;

    end.

    3)

    var s, s1:string; i:integer;

    begin

    read (s) ;

    for i:=length (s) downto 1 do

    s1:=s1+s[i];

    writeln (s1) ;

    end.

    4)

    var s:string; i, p1, p2:integer;

    begin

    read (s) ;

    for i:=1 to length (s) do begin

    if s[i]=' (' then p1:=i;

    if s[i]=') ' then p2:=i-p1;

    end;

    delete (s, p1, p2) ;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1) дана строка S определить и напечатать сколько символов * 2) дана строка S вместо каждого символа * записать символы 0 Напечатать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки. "выбрать из нее символы кратные 4 и напечатать их (т. е.
Ответы (1)
Дана строка, содержащая только английские буквы (большие и маленькие) и открывающиеся скобки. Сформировать новую строку добавлением справа "зеркальной" строки с закрывающимися скобками.
Ответы (1)
Составьте программу, которая позволяет удалить символы t из строки s. Строка s и символ t, который надо удалить, вводятся с клавиатуры
Ответы (1)
Дана строка. Удвоить каждый символ строки, выбрать из нее символы кратные 4 и напечатать её наоборот. Поясняю, символы кратные 4-ем, это значит каждый 4-ый символ строки.
Ответы (1)
Вася учится в школе. Недавно учитель записал на доске строку из строчных латинских букв и цифр, а Вася переписал эту строку в тетрадку. Придя домой, Вася столкнулся с проблемой в прочтении строки.
Ответы (1)