Задать вопрос
15 декабря, 05:52

Помогите решить в паскале

1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6.

2) Введено 3-значное число. Вывести число в зеркальном отображении.

3) Введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.

+5
Ответы (1)
  1. 15 декабря, 08:44
    0
    Program task1;

    var a : integer;

    begin

    randomize; a: = 0; while (a 5) and (a 6) do a: = random (7) ; writeln (a) ;

    end.

    program task2;

    var Digit, i : integer; DigitStr : string;

    begin

    readln (Digit) ; str (Digit, DigitStr) ; for i: = length (DigitStr) downto 1 do write (DigitStr[i]) ;

    end.

    program task3;

    var Digit : integer; NewDigit, DigitStr : string;

    begin

    readln (Digit) ; str (Digit, DigitStr) ; NewDigit: = DigitStr[3] + DigitStr[4] + DigitStr[1] + DigitStr[2]; writeln (NewDigit) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить в паскале 1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 0 до 1.
Ответы (1)
Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 10.
Ответы (1)
В паскале сформирвать массив из десяти элементов, заполнить его с помощью генератора случайных чисел и сделать так, чтобы в нем поменялись местами 1 и 2, 3 и 4 значение и так далее. Нужно написать программу.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)