Задать вопрос
14 февраля, 17:37

С клавиатуры вводится целое число K (K<=5). Найти и вывести на экран первые К совершенных числа.

Совершенное число - - натурально число, равное сумме всех своих собственных делителей (т. е. всех положительных делителей, отличных от самого числа).

Pascal ABC

функцией

+1
Ответы (1)
  1. 14 февраля, 21:27
    0
    Program n1;

    var k, i: longint;

    function sov (n: longint) : boolean;

    var i, sum: longint;

    begin

    i:=1;

    while i
    if ((n mod i) = 0) then

    begin

    sum:=sum+i;

    i:=i+1;

    end else i:=i+1;

    if sum=n then sov:=true else sov:=false;

    end;

    begin

    write ('k=') ;

    readln (k) ;

    for i:=1 to k do if sov (i) then write (i,' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С клавиатуры вводится целое число K (K ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
С клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестс клавиатуры вводится целое число n. найти произведение всех цифр этого числа а так же колличество больших шестии
Ответы (1)
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
1) Вычислить и вывести на экран сумму тех целых чисел из промежутка от 1 до K, которые не делятся на 5 без остатка. K вводится с клавиатуры. 2) С клавиатуры вводится целое положительное число. Определить, сколько в числе цифр.
Ответы (1)