Задать вопрос
4 октября, 07:11

Напишите программу на паскале)

1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше.

2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом.

3. С клавиатуры вводится 4-хзначное число. Определить, равна ли сумма первых двух цифр сумме последних двух.

+5
Ответы (1)
  1. 4 октября, 07:50
    0
    program pervoe;

    var a, b, c, c1, d, max:integer;

    begin

    readln (a) ;

    b:=a div 100;

    c: = a mod 10;

    c1: = a mod 100;

    d: = c1 div 10;

    if (b > c) then max: = b

    else max: = c;

    if (max < d) then max : = d; writeln (max) ;

    readln;

    end.

    2) program vtoroe;

    var a, b, c, c1, d, pro:integer;

    begin

    readln (a) ;

    b:=a div 100;

    c: = a mod 10;

    c1: = a mod 100;

    d: = c1 div 10;

    pro: = b * c * d;

    if (pro > 99) and (pro < 1000) then writeln ('Yes') ;

    readln;

    end.

    3) program trete;

    var a, b, c, d, e, f, g, j, sum1, sum2:integer;

    begin

    readln (a) ;

    b:=a div 1000; {1}

    c:=a mod 10; {4}

    e:=a mod 1000; {234}

    f:=e div 100; {2}

    g:=e mod 100; {34}

    j:=g div 10; {3}

    sum1: = b + f;

    sum2: = j + c;

    if (sum1 = sum2) then writeln ('Yes')

    else writeln ('NO') ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Шестизначный билет для проезда в любом транспортном средстве называется "счастливым по-ленинградски", если сумма первых трёх его цифр равна сумме трёх последних его цифр.
Ответы (2)
Дано четырехзначное число. определить равна ли сумма первых двух его цифр сумме двух его последних цифр. В паскале
Ответы (1)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Дано четырехзначное число. Написать программу, которая определяет равна ли сумма первых двух его цифр сумме двух его последних цифр.
Ответы (2)