Задать вопрос
4 октября, 04:29

Помогите с задачей на паскале

Дан одноименный массив А. Определить среднее арифметическое положительных и четных элементов больших 6.

+3
Ответы (1)
  1. 4 октября, 05:38
    0
    var a: array [1 ... 20] of integer;

    i, k: integer;

    s: real;

    begin

    for i:=1 to 20 do

    readln (a[i]) ;

    s : = 0;

    k : = 0;

    for i:=1 to 20 do

    if (a[i] >=0) and (a[i] mod 2=0) and (a[i]>6) then begin

    s : = s + a;

    k : = k + 1;

    end;

    writeln ('среднее: ', s/k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с задачей на паскале Дан одноименный массив А. Определить среднее арифметическое положительных и четных элементов больших 6. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одноименный массив А. Определить среднее арифметическое положительных и четных элементов больших 6. 2. Дан одноименный массив размером N.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)