Задать вопрос
30 июня, 20:54

1. Дан одноименный массив А. Определить среднее арифметическое положительных и четных элементов больших 6.

2. Дан одноименный массив размером N. Получить значение следующего выражения: макс*2/Nмакс (удвоенное значение максимального элемента поделить на его порядковый номер).

+2
Ответы (1)
  1. 30 июня, 21:12
    0
    1)

    var

    n, i, c, sum, sum2, c2: integer;

    a: array of integer;

    begin

    sum : = 0;

    sum2 : = 0;

    c2 : = 0;

    c : = 0;

    readln (n) ;

    setlength (a, n) ;

    for i : = 0 to n - 1 do

    begin

    read (a[i]) ;

    if (a[i] > 0) and (a[i] > 6) then

    begin

    sum : = sum + a[i];

    c : = c + 1;

    end;

    if (a[i] mod 2 = 0) and (a[i] > 6) then

    begin

    sum2 : = sum2 + a[i];

    c2 : = c2 + 1;

    end;

    end;

    writeln (sum / c) ;

    write (sum2 / c2) ;

    end.

    2)

    var

    n, i, max, im: integer;

    a: array of integer;

    begin

    im : = 1;

    readln (n) ;

    setlength (a, n) ;

    for i : = 0 to n - 1 do

    begin

    read (a[i]) ; if (i = 1) then max : = a[0];

    if (a[i] > max) then

    begin

    max : = a[i];

    im : = i + 1;

    end;

    end;

    write ((max * 2) / im) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дан одноименный массив А. Определить среднее арифметическое положительных и четных элементов больших 6. 2. Дан одноименный массив ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дан одномерный массив из N элементов. Заменить в нем значение макс и мин элемента на сумму всех элементов массива 2. Дан одномерный массив из Н элементов. Найти среднее арифметическое положительных четных элементов данного массива
Ответы (1)
1) дан массив. найти сумму положительных и нечетных и количество отрицательных четных элементов 2) Дан массив целых чисел.
Ответы (1)
дан массив из семи элементов написать программу подсчитывающую среднее второго и предпоследнего элементов массива дан целочисленный массив из 10 элементов написать программу находящую сумму элементов массива красных 3 ил 5 дан целочисленный массив
Ответы (1)
1) Дан массив из n элементов. Найти номер наименьшего элемента массива. 2) Дан массив из n элементов. Упорядочить массив по возрастанию. 3) Дан массив из n элементов. Упорядочить массив по убыванию.
Ответы (1)
Хотя бы 3-4 задачи! 1) Дан одномерный целочисленный массив размерностью N. Найдите количество элементов, которые кратны 3 (5). 2) Дан одномерный целочисленный массив А, состоящий из N элементов. Найти сумму всех четных элементов массива.
Ответы (1)