Задать вопрос
23 мая, 02:53

Шестизначный

билет для проезда в любом транспортном средстве называется "счастливым

по-ленинградски", если сумма первых трёх его цифр равна сумме трёх последних

его цифр. Определить, является ли билет с введённым с клавиатуры номером

"счастливым по-ленинградски".

Исходные

данные: в первой строке вводится номер

билета (6 цифр).

Результат

работы программы: во второй строке вывести

на экран текст "Билет счастливый", либо "Билет не является счастливым". помогите написать программу, я ее примерно написала, но не работает.

+1
Ответы (2)
  1. 23 мая, 03:37
    0
    Вариант 3:

    Function Sum (a : Integer) : Byte;

    Begin

    Sum:=a div 100 + a div 10 mod 10 + a mod 10;

    end;

    Var n : Integer;

    Begin

    Repeat

    Readln (n) ;

    Until (n>99999) and (n<=999999) ;

    If Sum (n div 1000) = Sum (n mod 1000) then Writeln ('Билет счастливый')

    else Writeln ('Билет не счастливый')

    end.
  2. 23 мая, 05:38
    0
    Вариант 1

    var s: string;

    begin

    read (s) ;

    if ord (s[1]) + ord (s[2]) + ord (s[3]) = ord (s[4]) + ord (s[5]) + ord (s[6])

    then writeln ('Билет счастливый')

    else writeln ('Билет не является счастливым') ;

    end.

    Вариант 2

    var n: integer;

    begin

    read (n) ;

    if n div 100000 + n div 10000 mod 10 + n div 1000 mod 10 = n div 100 mod 10 + n div 10 mod 10 + n mod 10

    then writeln ('Билет счастливый')

    else writeln ('Билет не является счастливым') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Шестизначный билет для проезда в любом транспортном средстве называется "счастливым по-ленинградски", если сумма первых трёх его цифр равна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу на паскале) 1. С клавиатуры вводится 3-хзначное число. Определить какая из его цифр больше. 2. С клавиатуры вводится 3-хзначное число. Определить является ли произведение его цифр 3-хзначным числом. 3.
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Трамвайный билет имеет шестизначный номер (от 100000 до 999999). Выяснить, является ли билет "счастливым". Билет назовем "счастливым", если сумма первых трёх чисел равна сумме трёх других чисел. Через цикл whili, а также div mod
Ответы (1)