Задать вопрос
6 июня, 03:22

1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них.

2. Составьте программу в Pascal ABC. Для данного вещественного x найти значение следующей функции f, принимающей вещественные значения:f (x) = (2-х) / x2, если x>0, иначе f (x) = 6-х3

3. Составьте программу в Pascal ABC. Даны два числа. Найти их сумму, разность и произведение.

+5
Ответы (1)
  1. 6 июня, 06:26
    0
    1 задача.

    var a, b, c: integer;

    begin

    write ('Введите через пробел три числа: ') ;

    readln (a, b, c) ;

    if (a > b) then

    if (b > c) then

    write ('Сумма двух наибольших чисел: ', a + b)

    else

    write ('Сумма двух наибольших чисел: ', a + c)

    else

    if (c > a) then

    write ('Сумма двух наибольших чисел: ', c + b)

    else

    write ('Сумма двух наибольших чисел: ', b + a)

    end.

    2 задача.

    var x, f: real;

    begin

    write ('Введите значение x: ') ;

    readln (x) ;

    if (x > 0) then

    f : = (2 - x) / (x * x)

    else

    f : = 6 - (x * x * x) ;

    writeln ('Значение функции при данном x: ', f)

    end.

    3 задача.

    var a, b: integer;

    write ('Введите через пробел два числа: ') ;

    readln (a, b) ;

    writeln ('Сумма чисел: ', a + b) ;

    writeln ('Разность чисел: ', a - b) ;

    writeln ('Произведение чисел: ', a * b)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Составьте программу в Pascal ABC. Даны три числа. Найти сумму двух наибольших из них. 2. Составьте программу в Pascal ABC. Для данного ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы