Задать вопрос
19 мая, 04:52

Даны

вещественные числа a, b, c. Выяснить, имеет ли уравнение ах2 + bx +

c = 0 вещественные корни.

Написать программу!

+1
Ответы (1)
  1. 19 мая, 08:24
    0
    Var a, b, c, d:real;

    begin

    write ('Введите коэффициенты a, b, c: ') ;

    readln (a, b, c) ;

    d: = (b*b-4*a*c) ;

    if d<0 then writeln ('Вещественных корней нет') ;

    if d=0 then writeln ('Один вещественный корень') ;

    if d>0 then writeln ('Два вещественных корня') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Даны вещественные числа a, b, c. Выяснить, имеет ли уравнение ах2 + bx + c = 0 вещественные корни. Написать программу! ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы