Задать вопрос
7 августа, 12:59

Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, определяющую общую длину пробега за месяц и первый день с начала тренировок, после которого дистанция превысит 25 км.

паскаль!

+5
Ответы (1)
  1. 7 августа, 14:01
    0
    const

    D: real = 10; / / число км в день

    p: real = 1.12; / / %

    M: integer = 30; / / число дней в месяце

    N: integer = 25; / / макс дистанция в условии задачи

    var c: integer;

    s, x: real;

    begin

    x : = D;

    for c : = 1 to M do begin

    s : = s + x;

    x : = x * p;

    end;

    writeln ('в месяц пробегает: ', s) ;

    x : = D; c : = 0;

    while (x < N) do begin

    c : = c + 1;

    x : = x * p;

    end;

    writeln ('Нужно ', c, ' дней') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Спортсмен, начав тренировки, в первый день пробежал 10 км. Каждый следующий день он увеличивал дистанцию на 12 %. Написать программу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок. Написать программу в Pascal
Ответы (1)
Написать программу на Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего.
Ответы (1)
Написать код в программе C#: 1 задание: Начав тренировки, лыжник в первый день пробежал 7 км. Каждый следующий день он увеличивал пробег на 12% от пробега предыдущего дня.
Ответы (1)
Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а) в какой день он пробежал больше 20 км.
Ответы (1)
Составить задачу в Паскале Начав тренировки лыжник в 1 день пробежал а км. Каждый следующий день он увеличивал пробег на b% от пробега предыдущего дня. Найти суммарный путь за n дней тренировок. Даю максимально очков.
Ответы (1)