Задать вопрос
18 марта, 23:55

Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а) в какой день он пробежал больше 20 км. б) в какой день суммарный пробег за все дни превысит 100 км? Задача по информатике, надо составить программу в pascal abc. Помогите!

+4
Ответы (1)
  1. 19 марта, 02:43
    0
    а)

    var

    i:integer;

    p:real;

    begin

    i:=1;

    p:=10;

    repeat

    p:=p + p*0.1;

    i:=i+1;

    until p>=20;

    writeln (i, ' den') ;

    end.

    б)

    var

    i:integer;

    p, n:real;

    begin

    i:=1;

    p:=10;

    n:=p;

    repeat

    n:=n+n*0.1;

    p:=p + n;

    i:=i+1;

    write (n) ;

    writeln (' ', p) ;

    until p>=100;

    writeln (i, ' den') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего Определить: а) В какой день он пробежит больше 20 км б) В какой день суммарный
Ответы (1)
Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок. Написать программу в Pascal
Ответы (1)
Написать программу на Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего.
Ответы (1)
Помогите написать на паскале Начав тренировки лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить пробег лыжника за второй, третий, ..., десятый день.
Ответы (1)
Написать код в программе C#: 1 задание: Начав тренировки, лыжник в первый день пробежал 7 км. Каждый следующий день он увеличивал пробег на 12% от пробега предыдущего дня.
Ответы (1)