Задать вопрос
10 января, 18:11

Написать программу на Паскале.

Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего. Определите в какой день он пробежит больше 20 км, и в какой день суммарный пробег за все дни превысит 100 км

+1
Ответы (1)
  1. 10 января, 21:13
    0
    Program abc;

    var a, b, i: real;

    begin

    a:=10; / / 10 км за день

    b:=1; / / счетчик дней

    Repeat

    a:=a+a*0.1; / / + 10% от пробега предыдущего

    b:=b+1; / / счетчик дней

    Until a>20; / / суммарный пробег за все дни превысит 20 км

    writeln ('Пробег превысил 20 км. на день № ', b) ;

    Repeat

    a:=a+a*0.1; / / + 10% от пробега предыдущего

    b:=b+1; / / счетчик дней

    Until a>100; / / суммарный пробег за все дни превысит 100 км

    writeln ('Пробег превысил 100 км. на день № ', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу на Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего Определить: а) В какой день он пробежит больше 20 км б) В какой день суммарный
Ответы (1)
Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок. Написать программу в Pascal
Ответы (1)
Начав тренировки, спортсмен пробежал в первый день 10 км. Каждый день он увеличивал дневную норму на 10% нормы предыдущего дня. Сколько он пробегал за каждый день тренировки? Какой суммарный путь пробежит спортсмен за 7 дней?
Ответы (1)
Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а) в какой день он пробежал больше 20 км.
Ответы (1)
Помогите написать на паскале Начав тренировки лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить пробег лыжника за второй, третий, ..., десятый день.
Ответы (1)