Задать вопрос
22 января, 13:05

Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок.

Написать программу в Pascal

+4
Ответы (1)
  1. 22 января, 14:32
    0
    Program lyg;

    var

    all, last, seven: real;

    ii, day: integer;

    begin

    last : = 10;

    all : = 10;

    day : = 0;

    for ii : = 1 to 10 do

    begin

    last : = last + (last*0.1) ;

    all : = all+last;

    if ii=7 then

    seven : = all;

    writeln ('day ', ii,': ', round (last)) ;

    if day = 0 then

    if all > 100 then

    day : = ii;

    end;

    writeln ('Overall distance of 7 days: ', seven) ;

    writeln ('Distance 100km is reached at ', day,' day') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Написать код в программе C#: 1 задание: Начав тренировки, лыжник в первый день пробежал 7 км. Каждый следующий день он увеличивал пробег на 12% от пробега предыдущего дня.
Ответы (1)
Составить задачу в Паскале Начав тренировки лыжник в 1 день пробежал а км. Каждый следующий день он увеличивал пробег на b% от пробега предыдущего дня. Найти суммарный путь за n дней тренировок. Даю максимально очков.
Ответы (1)
Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего Определить: а) В какой день он пробежит больше 20 км б) В какой день суммарный
Ответы (1)
Помогите написать на паскале Начав тренировки лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить пробег лыжника за второй, третий, ..., десятый день.
Ответы (1)
Начав тренировку лыжник в 1 день пробежал 10 км. Каждый след. день он увеличивал длину пробега на 10% от пробега предыдущего дня. Определить: а) в какой день он пробежал больше 20 км.
Ответы (1)