Задать вопрос
12 ноября, 13:27

Составить задачу в Паскале

Начав тренировки лыжник в 1 день пробежал а км. Каждый следующий день он увеличивал пробег на b% от пробега предыдущего дня. Найти суммарный путь за n дней тренировок.

Даю максимально очков.

+3
Ответы (1)
  1. 12 ноября, 14:24
    0
    Program pr1;

    Uses Crt;

    Var

    n, i:integer;

    a, b, s:real;

    begin

    ClrScr;

    writeln ('В 1 день лыжник пробежал? км:') ;

    readln (a) ;

    writeln ('Лыжник увеличивал пробег на? %:') ;

    readln (b) ;

    writeln ('Лыжник бежал? дней:') ;

    readln (n) ;

    s:=0;

    for i:=1 to n do

    begin

    s:=s+a;

    a:=a * (1+b/100) ;

    end;

    writeln ('Лыжник пробежал всего:', s) ;

    readln;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить задачу в Паскале Начав тренировки лыжник в 1 день пробежал а км. Каждый следующий день он увеличивал пробег на b% от пробега ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить какой суммарный путь он пробежал за первые 7 дней тренировок. Написать программу в Pascal
Ответы (1)
Написать код в программе C#: 1 задание: Начав тренировки, лыжник в первый день пробежал 7 км. Каждый следующий день он увеличивал пробег на 12% от пробега предыдущего дня.
Ответы (1)
Помогите написать на паскале Начав тренировки лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего дня. Определить пробег лыжника за второй, третий, ..., десятый день.
Ответы (1)
Помогите записать задачу в Turbo Pascalе Начав тренировки, лыжник в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего Определить: а) В какой день он пробежит больше 20 км б) В какой день суммарный
Ответы (1)
Написать программу на Паскале. Начав тренировки, спортсмен в первый день пробежал 10 км. Каждый следующий день он увеличивал пробег на 10% от пробега предыдущего.
Ответы (1)