Задать вопрос
20 июля, 10:39

Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр

+2
Ответы (1)
  1. 20 июля, 12:56
    0
    Var

    A: integer;

    begin

    readLn (A) ;

    if (A mod 2 = 0) then

    begin

    A : = sqr (A) ;

    WriteLn ('Квадрат введённого числа равен: ', A) ;

    end else

    begin

    A : = ((A mod 100) div 10) + (A mod 10) + (A div 100) ;

    writeLn ('Сумма цифр введённого числа равна: ', A) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы