Задать вопрос
5 мая, 16:13

Составить программу, которая:

а) из слов "программа"составляет слова: " грамм", "рога", "гора";

б) из слов " страх", "белка", "цыпленок" получает слово"столбец";

в) считает, сколько раз в тексте, заданном с клавиатуры, встречается, фрагмент "ба".

+5
Ответы (1)
  1. 5 мая, 17:24
    0
    Program z1; var s, s1, s2, s3, s4, s5, s6, s7, s8:string; begin s:='программа'; s1:=copy (s, 4, 4) ; s4:=copy (s, 2, 3) ; s5:=copy (s, 2, 1) ; s2:=s4+s5; s6:=copy (s, 4, 1) ; s7:=copy (s, 3, 1) ; s8:=copy (s, 5, 2) ; s3:=s6+s7+s8; writeln (s1, s2, s3) ; end. Посмотри, это пункт а. Если то, что нужно, сделаю остальные ... Program z1; var s, s1, s2, s3, st, o, l, be, c: string; begin s1:='страх'; s2:='белка'; s3:='цыпленок'; st:=copy (s1, 1, 2) ; o:=copy (s3, 7, 1) ; l:=copy (s2, 3, 1) ; be:=copy (s2, 1, 2) ; c:=copy (s3, 1, 1) ; s:=st+o+l+be+c; writeln (s) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая: а) из слов "программа"составляет слова: " грамм", "рога", "гора"; б) из слов " страх", "белка", "цыпленок" ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составьте программу, которая: считает, сколько раз в тексте, заданном с клавиатуры, встречается буква "М". решение паскаль через цикл
Ответы (1)
Составьте программу, которая считает, сколько раз в тексте, заданном с клавиатуры, встречается буква "М" Текст: Мой компьютер сломан в бейсике
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
Помогите: Практическая работа №3. Ветвления Уровень A. Напишите программу, которая получает с клавиатуры два целых числа и находит наибольшее и наименьшее из них. Пример: Введите два числа: 1 5 Наименьшее число 1 Наибольшее число 5 Уровень B.
Ответы (1)
1. Напишите программу, которая в последовательности натуральных чисел определяет количество чисел, кратных 4. Программа получает на вход количество чисел в последовательности, а затем сами числа. В последовательности всегда имеется число, кратное 4.
Ответы (1)