Задать вопрос
5 декабря, 05:40

Программа в Pascal

1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м.

2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о

+5
Ответы (1)
  1. 5 декабря, 06:11
    0
    1. Program prog;

    uses crt;

    var s: string;

    k, i: integer;

    begin;

    write ('S = ') ;

    readln (s) ;

    for i:=1 to length (s) do

    if (s[i]='м') or (s[i]='М') then k:=k+1;

    writeln (k) ;

    end.

    2. Program prog;

    uses crt;

    var

    s, n:string;

    i:integer;

    begin

    write ('S = ') ;

    readln (s) ;

    n:='';

    for i:=1 to length (s) do

    if (s[i]'о') and (s[i]'О') then

    n:=n+s[i];

    s:=n;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу в Pascal 1) в строке, введенной с клавиатуры, все буквы И заменить на % 2) из строки, введенной с клавиатуры, удалить все символы, начиная с середины.
Ответы (1)
1. С клавиатуры вводится слово, распечатать все его буквы через пробел. (после последней буквы пробела быть не должно). 2. Написать программу, которая удаляет первое слово из строки введенной с клавиатуры и вместо него вставляет заданное.
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)
Написать программу, которая определяет максимальное число из введенной с клавиатуры последовательности положительных чисел (длина последовательности не ограничена) Программа Паскаль Цикл с пост условием
Ответы (1)