Задать вопрос
15 марта, 23:14

Помогите решить две задичи

Задача: Написать программу, которая

а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран

б) удаляет все буквы 'а' из строки и выводит новую строку на экран

+2
Ответы (1)
  1. 15 марта, 23:43
    0
    Var st:string;

    i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (st) ;

    for i:=1 to length (st) do begin

    if st[i]='a' then

    st[i]:='o';

    end;

    writeln (st) ;

    end.

    var st:string;

    i:integer;

    begin

    writeln ('Введите строку:') ;

    readln (st) ;

    for i:=1 to length (st) do begin

    if st[i]='a' then

    delete (st, i, 1) ;

    end;

    writeln (st) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
задача 1 Cоставить программу, которая позволяет ввести строку s, затем после каждой буквы "а" вставить пробел. задача 2 Составить программу, которая удаляет в строке S все буквы "о"
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)
Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число.
Ответы (1)