Задать вопрос
20 июня, 21:49

задача 1

Cоставить программу, которая позволяет ввести строку s, затем после каждой буквы "а" вставить пробел.

задача 2

Составить программу, которая удаляет в строке S все буквы "о"

+5
Ответы (1)
  1. 20 июня, 23:06
    0
    На всякий случай сделал проверку и на русские, и на английские.

    задача 1.

    uses crt;

    var i:integer;

    s:string;

    begin

    i:=1;

    read (s) ;

    repeat

    if (s[i]='a') or (s[i]='а') then

    s:=copy (s, 1, i) + ' '+copy (s, i+1, length (s)) ;

    i:=i+1;

    until i=length (s) + 1;

    writeln (s) ;

    end.

    задача 2.

    uses crt;

    var i:integer;

    s:string;

    begin

    i:=1;

    read (s) ;

    repeat

    if (s[i]='о') or (s[i]='o') then

    s:=copy (s, 1, i-1) + ' '+copy (s, i+1, length (s)) ;

    i:=i+1;

    until i=length (s) + 1;

    writeln (s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «задача 1 Cоставить программу, которая позволяет ввести строку s, затем после каждой буквы "а" вставить пробел. задача 2 Составить ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить две задичи Задача: Написать программу, которая а) все буквы 'а' в строке st заменяет на букву 'о' и выводит новую строку на экран б) удаляет все буквы 'а' из строки и выводит новую строку на экран
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1. С клавиатуры вводится слово, распечатать все его буквы через пробел. (после последней буквы пробела быть не должно). 2. Написать программу, которая удаляет первое слово из строки введенной с клавиатуры и вместо него вставляет заданное.
Ответы (1)
Программы с процедурой вставки В строку s1 занесите свои фамилию и отчество (через пробел). В строку s2 занесите свое имя. С помощью процедуры вставки измените строку s1 таким образом, чтобы она содержала Ваши фамилию, имя, отчество.
Ответы (1)
Программа в Pascal 1. Написать программу которая определяет сколько раз в строке, введенной с клавиатуры, встречается буква м. 2. написать программу которая удаляет из строки, введенной с клавиатуры, все буквы о
Ответы (1)