Задать вопрос
16 марта, 00:34

Множество А содержит все нечетные числа из диапаазона от 1 до 200

Множесто В - простые числа из этого же диапазона.

Определить дополнение множества В до множества А.

Задачка на Паскале.

+5
Ответы (1)
  1. 16 марта, 02:32
    0
    Var i, j, simple_n, res_n : integer;

    Res, Simple: array[1 ... 100] of integer;

    Found:boolean;

    Begin

    for i : = 2 to 200 do begin

    found : = false;

    for j : = 1 to simple_n do

    found : = found or (i mod Simple[j] = 0) ;

    if found and (i mod 2 = 1) then begin

    res_n : = res_n + 1;

    Res[res_n] : = i;

    writeln ('Res = ', Res[res_n]:4) ;

    end;

    if not found then begin

    simple_n : = simple_n + 1;

    Simple[simple_n] : = i;

    writeln ('Simple = ', Simple[simple_n]:4) ;

    end;

    end;

    for i : = 1 to res_n do

    write (Res[i]:4) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Множество А содержит все нечетные числа из диапаазона от 1 до 200 Множесто В - простые числа из этого же диапазона. Определить дополнение ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
в школьном саду растут только фруктовые деревья: яблони, груши, сливы, вишни. Подчеркни верные высказывания: 1. Множество слив является подмножеством множества фруктовых деревьев. 2. множество фруктовых деревьев равно множеству деревьев. 3.
Ответы (2)
С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры). 2. Найти среднее арифметическое всех целых чисел от 1 до 1000. 3.
Ответы (1)
Равные множества? Множества детей-множество первоклассников. Множество школьников-множество учеников 1 А класса. Множество учеников первых классов-множество учеников
Ответы (1)
Пусть есть высказывание А есть: "Множество А есть подмножество множества В ", высказывание В есть: "Все элементы множества А являются элементами множества В".
Ответы (1)
Даны множества: А-множество фруктов в корзине В-множество яблок в этой корзине С-множество зеленых яблок в этой корзине Р-множество груш в этой корзине.
Ответы (1)