Задать вопрос
15 февраля, 16:03

С++

Так что бы программа просила в вести значение на русском

1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 (значение a вводится с клавиатуры).

2. Найти среднее арифметическое всех целых чисел от 1 до 1000.

3. Пользователь вводит две границы диапазона, вывести на экран все числа из этого диапазона. Предусмотреть, чтобы пользователь мог вводить границы диапазона в произвольном порядке.

вывести все четные числа из диапазона.

вывести все нечетные числа из диапазона.

вывести все числа, кратные семи

4. Пользователь с клавиатуры вводит числа. Посчитать их сумму и вывести на экран, как только пользователь введет ноль.

+3
Ответы (1)
  1. 15 февраля, 17:50
    0
    1.

    #include

    using namespace std;

    void main ()

    {

    //задаём русский язык для консоли

    setlocale (LC_ALL, "Russian") ;

    long sum = 0;

    int a;

    cout << "Введите a" << endl;

    cin >> a;

    if (a > 500)

    {

    cout < 500" << endl;

    }

    else

    {

    sum = (500 * 501 / 2) - ((a - 1) * a) / 2;

    cout << sum;

    }

    }

    2.

    #include

    using namespace std;

    void main ()

    {

    //задаём русский язык для консоли

    setlocale (LC_ALL, "Russian") ;

    double average = (1 + 1000) / 2.;

    cout << "Среднее арифметические чисел от 1 до 1000" << average << endl;

    }

    3

    #include

    using namespace std;

    void main ()

    {

    //задаём русский язык для консоли

    setlocale (LC_ALL, "Russian") ;

    int a = 0, b = 0;

    cout << "Введите границы диапазона" << endl;

    cin >> a >> b;

    cout << "Все числа:" << endl;

    if (a < = b)

    {

    for (int i = a; i < = b; i++)

    {

    cout << i << endl;

    }

    }

    else

    {

    for (int i = b; i < a; i++)

    {

    cout << i << endl;

    }

    }

    cout << "Чётные числа:" << endl;

    if (a < = b)

    {

    for (int i = a; i < = b; i++)

    {

    if (i % 2 = = 0)

    {

    cout << i << endl;

    }

    }

    }

    else

    {

    for (int i = b; i < a; i++)

    {

    if (i % 2 = = 0)

    {

    cout << i << endl;

    }

    }

    }

    cout << "Нечётные числа:" << endl;

    if (a < = b)

    {

    for (int i = a; i < = b; i++)

    {

    if (i % 2! = 0)

    {

    cout << i << endl;

    }

    }

    }

    else

    {

    for (int i = b; i < a; i++)

    {

    if (i % 2! = 0)

    {

    cout << i << endl;

    }

    }

    }

    cout << "Числа, кратные 7:" << endl;

    if (a < = b)

    {

    for (int i = a; i < = b; i++)

    {

    if (i % 7 = = 0)

    {

    cout << i << endl;

    }

    }

    }

    else

    {

    for (int i = b; i < a; i++)

    {

    if (i % 7 = = 0)

    {

    cout << i << endl;

    }

    }

    }

    }

    4.

    #include

    using namespace std;

    void main ()

    {

    //задаём русский язык для консоли

    setlocale (LC_ALL, "Russian") ;

    int a = 0, sum = 0;

    cout << "Введите числа" << endl;

    while (true)

    {

    cin >> a;

    if (a = = 0)

    {

    break;

    }

    sum + = a;

    }

    cout << "Сумма = " << sum << endl;

    }
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «С++ Так что бы программа просила в вести значение на русском 1. Напишите программу, которая вычисляет сумму целых чисел от а до 500 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Программирование в python 3 Напечатать массив и сумму его первых N десятков. Пример: Пользователь вводит любое число, например 56 Программа выдаёт на экран массив от 0 до 55 и ещё пять чисел: сумму первых 10, сумму первых 20, сумму первых 30, сумму
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Найти: а) сумму всех целых чисел от 100 до 500; б) сумму всех целых чисел от a до 500 (значение a вводится с клавиатуры; a 500) ; в) сумму всех целых чисел от - 10 до b (значение b вводится с клавиатуры; b - 10) ;
Ответы (1)
3. Напишите и выполните программу на компьютере a. Программа вводит одно число, и вычисляет его квадрат, вычитая из него удвоенное значение введенного числа. b. Программа вводит два числа, выводит сумму квадратов этих чисел минус их произведение. c.
Ответы (1)