Задать вопрос
23 декабря, 00:06

Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число. Написать программу, которая заменяет его на 0, если число отрицательное, и выводит его без изменений, противном случае. Задача 3) Дано целое число n. Написать программу увеличивающую его на 10, если число больше 0.

+4
Ответы (1)
  1. 23 декабря, 02:05
    0
    Задача 1

    var

    a, b:Integer;

    Begin

    Read (a, b) ;

    if (a>b) then Writeln (b)

    else if (a
    else Writeln ('Числа равны') ;

    end.

    Задача 2

    var

    n:Integer;

    Begin

    Read (n) ;

    if (n<0) then Writeln (0)

    else Writeln (n) ;

    end.

    3 адача 3.

    var

    n:Integer;

    Begin

    Read (n) ;

    if (n>0) then Writeln (n+10)

    else Writeln (n) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано целое число. Написать программу которая заменяет его на 0, если число отрицательное и выводит его без изменений в пративном случае.
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
1) Дано целое число N. Написать программу, заменяющую его 1, если число меньше нуля, и увеличивающую его на 6, если число больше или равно нулю. 2) Даны два числа a и b. Написать программу, которая выводит номер большего из них
Ответы (1)
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)