Задать вопрос
28 мая, 08:58

Дано целое число. Написать программу которая заменяет его на 0, если число отрицательное и выводит его без изменений в пративном случае.

+5
Ответы (1)
  1. 28 мая, 12:39
    0
    В паскале АВС выглядит так:

    program dz;

    var a:integer;

    begin

    readln (a) ;

    if a<0 then a:=0;

    writeln (a) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано целое число. Написать программу которая заменяет его на 0, если число отрицательное и выводит его без изменений в пративном случае. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Задача 1) Даны два числа а и b. Написать программу, которая находит меньшее из них и выводит на экран соответствующий результат. Задача 2) Дано целое число.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Задача 1 - Дано целое число. Если оно положительное, вывести " Число положительное ", если отрицательное вывести "Число отрицательное ", если равно 0 - "Число равно нулю" задача 2 - дано целое число.
Ответы (1)
Помогите по программе paskal: 1. дано целое число. напишите программу которая уменьшает на 2 модуль этого числа и выводит на экран монитора результат 2. дано целое число.
Ответы (1)
1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c.
Ответы (1)