Задать вопрос
24 января, 18:12

Составьте программу которая находит сумму цифр трех значного числа на PascalABC

+5
Ответы (2)
  1. 24 января, 19:46
    0
    Program n1;

    var a: integer;

    begin

    readln (a) ;

    a:=abs (a) ;

    write ((a div 100) + (a mod 10) + (a mod 100 div 10)) ;

    end.
  2. 24 января, 20:36
    0
    Var

    i, n, s: Integer;

    begin

    write ('Введите трехзначное число ') ;

    read (n) ;

    i:=0;

    while (n0) Do

    begin

    s : = n Mod 10;

    i:=i+s;

    n: = n Div 10;

    end;

    writeLn ('Сумма цифр : ', i)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая находит сумму цифр трех значного числа на PascalABC ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Помогите составить программу на языке С! С клавиатуры вводится целое число. Определить кол-во цифр в нем, сумму его цифр, произведение его цифр, среднее арифметическое его цифр, сумму квадратов его цифр, сумму кубов его цифр.
Ответы (1)