Задать вопрос
24 мая, 19:19

написать программу, которая для трёхзначного числа, если оно четное, то возводит в квадрат, а если нечётное, то находит сумму цифр.

+3
Ответы (1)
  1. 24 мая, 22:52
    0
    Var a:integer;

    begin

    readln (a) ;

    if a mod 2 = 0 then writeln (a*a) else

    writeln ((a div 100) + (a mod 10) + ((a mod 100) div 10)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «написать программу, которая для трёхзначного числа, если оно четное, то возводит в квадрат, а если нечётное, то находит сумму цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр
Ответы (1)
Составить программу, которая чётное число возводит в квадрат, а не чётное в куб
Ответы (1)
Составте программу, вычисления суммы цифр трёхзначного числа а. Значение а введите с клавиатуры Пример ввода: 375 Пример вывода: Сумма цифр числа 375 равна 15 2) Составте программу, которая получает 'перевёртыш' трёхзначного числа а.
Ответы (1)
1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c.
Ответы (1)
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)