Задать вопрос
8 июня, 06:26

Составить программу, которая чётное число возводит в квадрат, а не чётное в куб

+1
Ответы (1)
  1. 8 июня, 08:23
    0
    Var a, b: integer;

    begin

    readln (a) ;

    if a mod 2 = 0 then

    b: = a*a

    else

    b: = a*a*a;

    writeln (b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу, которая чётное число возводит в квадрат, а не чётное в куб ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Дано целое число c. Напишите программу, которая возводит в квадрат частное от целочисленного деления числа c на 5 и выводит на экран монитора результат. 2. Дано целое число c.
Ответы (1)
Помогите! написать программу которая для 3 х значного числа если оно четное то возводит в квадрат, а если не четное то находит сумму цифр
Ответы (1)
написать программу, которая для трёхзначного числа, если оно четное, то возводит в квадрат, а если нечётное, то находит сумму цифр.
Ответы (1)
Составить программу - калькулятор, которая запрашивает тип математической функции: 1-квадрат, 2-куб, 3 - корень квадратный, 4 - обратная функция, а также аргумент функции x и вычисляет для x соответствующую математическую функцию.
Ответы (1)
Составить программу, которая запрашивает целое число, не равное нулю, сообщает, положительное оно или отрицательное. и при этом положительное число уменьшает в 2 раза, а отрицательное возводит в квадрат.
Ответы (1)