Задать вопрос
14 ноября, 23:54

Задача "Справедливое распределение"

У Андрея было А грамм крупы, у Бориса - В

грамм, а у Сергея вообще не было крупы.

Ребята сварили кашу и разделили ее поровну

на троих. Поскольку Сергей был без крупы, то

в благодарность за кашу он отдал С конфет

Андрею с Борисом.

Требуется написать программу, которая

определяет, как Андрей и Борис должны

поделить конфеты по справедливости.

Конфеты делить на части нельзя.

Описание входных данных

Входные данные вводятся с клавиатуры или

из файла input. txt. В единственной

строке записаны три целых числа А, В и С.

Описание выходных данных

Выходные данные выводятся на экран или в

файл output. txt. В единственной

строке необходимо вывести два целых числа

- количество конфет у Андрея и количество

конфет у Бориса.

Пример входных и выходных данных

Входные данные Выходные данные

700 500 12 9 3

+1
Ответы (1)
  1. 15 ноября, 02:10
    0
    Var a, b, c:real;

    begin

    readln (a, b, c) ;

    writeln (round (c / (a/b)),' ', c-round (c / (a/b))) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задача "Справедливое распределение" У Андрея было А грамм крупы, у Бориса - В грамм, а у Сергея вообще не было крупы. Ребята сварили кашу и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая сортирует массив целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Напишите программу, которая сортирует массив ненулевых целых чисел в порядке возрастания (неубывания). Размер массива заранее неизвестен. Исходные данные записаны в файл input. txt, отсортированный массив нужно вывести в файл output. txt.
Ответы (1)
Решето Эратосфена в PascalABC Данные вводятся с клавиатуры или из файла input. txt, выводятся на экран или в файл output. txt. Первые тесты не всегда совпадают с примерами из условия.
Ответы (1)
Даны два файла: input. txt и output. txt. В input. txt дана последовательность чисел: 1,6,11,16,21. В Output. txt отобразить размах ряда (т. е разность между наибольшим и наименьшим числом). Pascal
Ответы (1)
Помогите отредактировать программу - Паскаль. Где-то ошибка. Необходимо удалить первый кратный 3 элемент массива. program udalenie; var i, n, k:integer; a:array[1 ... 1000] of integer; begin assign (input,'input. txt') ; assign (output,'output.
Ответы (1)