Задать вопрос
15 октября, 04:09

Помогите с паскалем ...

Задали задание, написать программу формирования одномерного массива размера M. Полученный массив напечатать. Выполнить обработку и проебразование массива в соответствии со своим вариантом (Вычислить максимальный элемент массива. Заменить в массиве все нечетные на 1. Если нечетных чисел нет, вывести сообщение об этом.) Напечатать проебразованный массив. Подобрать контрольный пример.

+4
Ответы (1)
  1. 15 октября, 05:41
    0
    Решение:

    const M = 10;

    var a : array [1 ... M] of integer;

    i, max, odd : integer;

    begin

    odd : = 0;

    {Заполнение массива}

    for i : = 1 to M do

    begin

    write ('Input a[', i,']:') ;

    readln (a[i]) ;

    end;

    {Вывод массива на экран}

    for i : = 1 to M do

    write (a[i]:2,' ') ;

    writeln;

    {Поиск максимального в массиве}

    max : = a[1];

    for i : = 2 to M do

    if (a[i] > max) then

    max : = a[i];

    writeln ('Максимальный элемент массива: ', max) ;

    {Поиск всех нечетных чисел в массиве и замена их на 1}

    for i : = 1 to M do

    if (a[i] mod 2 = 1) then

    begin

    a[i] : = 1;

    odd : = 666;

    end;

    {Вывод сообщения об отсутствии нечетных чисел}

    if (odd = 0) then

    writeln ('В массиве нечетных чисел нет') ;

    {Вывод преобразованного массива}

    for i : = 1 to M do

    write (a[i]:2,' ') ;

    writeln;

    readln;

    end.

    В фигурных скобках - комментарии, из программы можно удалять безболезненно. M - количество элементов в массиве.

    Контрольные примеры для массива из 10 элементов:

    1) Массив "1 2 3 4 5 6 7 8 9 10" будет преобразован в "1 2 1 4 1 6 1 8 1 10", максимальный элемент (до преобразования) 10

    2) Массив " 2 2 2 2 2 2 2 2 2 2" будет преобразован в " 2 2 2 2 2 2 2 2 2 2", на экран будет выведено сообщение "в массиве нечетных чисел нет", максимальный элемент 2
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите с паскалем ... Задали задание, написать программу формирования одномерного массива размера M. Полученный массив напечатать. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить задачи! 1. Дан массив размера 10, числовые значения которого вводятся с клавиатуры. Вывести максимальный элемент данного массива и его номер. 2. Дан массив размера 10, числовые значения которого вводятся с клавиатуры.
Ответы (1)
Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется. Входные данные Первая строка содержит размер массива N.
Ответы (1)
Друг попросил найти ему как сделать прогу в Pascal, сам он работает и нет времени на это, вообщем нужно доработать вот эти коды, переделать всё в один код и чтобы работал, сама суть программы такая - Задать массив генератором случайных чисел в
Ответы (1)
1. Дан двумерный массив размером 3x5. Вычислить сумму элементов массива 2. Дан массив целых чисел размеров 4 х4. Заменить все элементы главной диагонали на нули. Вывести на экран монитора содержимое массива до обработки и после обработки 3.
Ответы (1)
Напишите решение задачи через паскаль. 1. Массив из 10 целых чисел из промежутка [10,20] задается с помощью гениратора случайных чисел. Вывести полученный массив в строку. Затем увеличить каждый элемент на 5.
Ответы (1)