Задать вопрос
20 ноября, 20:31

Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не повторяется.

Входные данные

Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. Гарантируется, что 0 < N ≤ 10000.

Выходные данные

Программа должна вывести максимальный повторяющийся элемент в массиве или число - 1, если ни один элемент не повторяется.

+4
Ответы (1)
  1. 21 ноября, 00:00
    0
    Var

    a:array [1 ... 10000] of integer;

    i, n, a_max, c;

    begin

    read (n) ;

    a_max:=0;

    c:=0;

    for i:=1 to n do

    begin

    a[i] : = random (100) ; / / автозаполнение массива

    print (a[i]) ;

    if a[i]>a_max then a_max:=a[i]; / / поиск максимального элемента

    end;

    writeln;

    for i:=1 to n do

    if a[i]=a_max then inc (c) ; / / поиск повторяющихся элементов

    if c>=2 then write (a_max)

    else write (-1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая находит в массиве максимальный повторяющийся элемент или выводит число - 1, если ни один элемент не ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Python Напишите программу, которая находит в массиве минимальный и максимальный из чётных положительных элементов. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу, которая выводит номера элементов массива, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива. В третьей строке записано число X.
Ответы (1)
Python! Напишите программу, которая находит в массиве количество элементов, равных максимальному. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Питон Напишите программу, которая находит в массиве количество элементов, равных заданному значению X. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)
Напишите программу, которая выбирает в другой массив каждый третий элемент исходного массива, начиная с первого. Входные данные Первая строка содержит размер массива N. Во второй строке через пробел задаются N чисел - элементы массива.
Ответы (1)